Software para lenguage musical

Bienvenidos a la web de mi proyecto.

LenMus es un proyecto abierto, comprometido con los principios del software libre, la educación gratuita y el libre acceso a la información. No tiene objetivos comerciales.

Es un proyecto personal, un hobby para aprender y divertirme, que realizo en mi tiempo libre. Así que no esperes nuevas versiones cada pocos meses. . ¡Lo siento!

 

LenMus news Noticias

1/Sep/2016 - Publicada la versión 0.20.0 de la librería Lomse

El desarrollo prosigue. El algoritmo de espaciado ha sido sustituido. Mejoras en el algoritmo de partición en sistemas. El renderizado se ha mejorado en algunos aspectos, entre ellos, en las letras para la música (lyrics); el ancho de las sílabas es ahora tenido en cuenta para el espaciado de las notas. Tambien se incrementa la distancia entre los pentagramas cuando hay letras. Se ha añadido soporte en LDP para: letras de canciones, acentos, símbolos de dinámica, grupos de instrumentos y títulos de las partituras. También opciones para tener pleno control sobre la justificación y el truncamiento del último sistema. Adicionalmente, se han corregido varios errores y se han añadido algunas otras pequeñas mejoras. Para detalles ver el log de cambios. En la PPA de Lomse están disponibles paquetes Debian para instalar Lomse en Ubuntu.

3/Jul/2016 - Actualización de la documentación

En los últimos meses he estado escribiendo y actualizando la documentación. El documento LDP language manual, v.2.0 no está aún terminado pero está mucho mas actualizado que el antiguo documento para la versión 1.5. Espero acabarlo a lo largo de este verano. Y he añadido un nuevo documento, API documentation for the Lomse library para facilitar el uso de la librería Lomse.

14/Feb/2016 - El desarrollo se mueve a GitHub

Hace unos dias inicié la migración del gestor de tareas de LenMus y los repositorios a GitHub. Desde hoy el desarrollo continua en GitHub, utilizando Git en vez de Bazaar para gestionar los repositorios. La página de LenMus en GitHub está aquí. Entra, mira, añade estrellas al proyecto, o haz un 'fork' del repositorio y contribuye!

28/Dic/2015 - Nueva sección para gestionar el proyecto

He comenzado a crear nuevas páginas para facilitar la colaboración en el desarrollo y gestión del proyecto. En el menú de la parte superior de las páginas aparece ahora un nuevo enlace "DEVELOPMENT" del que cuelgan, entre otros, el gestor de errores y tareas. ¿Quieres colaborar en LenMus?.

18/Dic/2015 - Liberada la versión 5.4 de Phonascus

Esta es una versión de mantenimiento para corregir un error que impedía la correcta instalación de la documentación de ayuda. Ver la lista de cambios para más detalles. En la PPA de LenMus están disponibles paquetes Debian para instalar en Ubuntu.

26/Sep/2015 - Liberada la versión 5.4 de Phonascus

El objetivo principal de esta nueva versión es simplificar la instalación. Para ello, se ha modificado la forma de construir e instalar el paquete, eliminando la dependencia de la librería Lomse, que causaba muchos problemas de instalación. Desafortunadamente, cuesta mucho preparar una nueva versión sin incluir todo el nuevo código que está en desarrollo. Por ello, esta versión incluye varias nuevas funcionalidades aún sin terminar, aunque por defecto están inhabilitadas. Ver la lista de cambios para más detalles. En la PPA de LenMus están disponibles paquetes Debian para instalar en Ubuntu.

7/Sep/2015 - Publicada la versión 0.16.1 de la librería Lomse

Esta nueva versión contiene, fundamentalemente, cambios para utilizar fonts de música que cumplan el estandar SMuFL y para soportar más elementos de notación musical. Y se han corregido algunos errores. Para más detalles consultar el log de cambios. En la PPA de Lomse están disponibles paquetes Debian para instalar Lomse en Ubuntu. Los tutoriales en esta web han sido actualizados.

27/Abr/2015 - Publicada la versión 0.15.0 de la librería Lomse

El desarrollo continúa y desde la versión 0.14.0 se ha añandido mucho código orientado, fundamentalmente, a soportar aplicaciones para edición de partituras y documentos. Para detalles ver el log de cambios. En la PPA de Lomse están disponibles paquetes Debian para instalar Lomse en Ubuntu. Los tutoriales en esta web han sido actualizados.

26/Ene/2015 - Instrucciones para instalar Phonascus en Mac OS X

Por ahora no hay versión para Mac de Phonascus. Yo no tengo un equipo Mac y no puedo prepararla. Pero es posible instalar en un Mac la versión Windows de Phonascus. Charles Nichols la ha instalado y probado en un Mac con OS X Yosemite y ha preparado unas instrucciones detalladas para instalarlo ¡Gracias Charles!

12/Ene/2015 - Publicada la versión 2.0 de wxMidi

La version 2.0 fundamentalmente corrige un error que causaba problemas ocasionales en la recepción de mensajes SysEx. Además incorpora algunas mejoras y elimina la limitación a 32KB para mensajes SysEx. Se han añadido dos nuevas traducciones: Alemán, gracias a Undine Peters; y a Chino simplificado, gracias a 卢文汐 (Wenxi Lu). La documentación se ha actualizado y reescrito con Doxygen. Ver la lista de cambios para más detalles.

03/May/2013 - Liberada la versión 5.3.1 de Phonascus

La versión 5.3.1 está orientada a eliminar errores, en particular todos los que provocaban la finalización inesperada del programa. También se completa la traducción a Chino y se incluyen opciones en el ejercicio de lectura de claves. Ver la lista de cambios para más detalles.

Para estudiantes de música

LenMus Phonascus

LenMus screenshots

Phonascus es un software gratuito para el aprendizaje del lenguaje musical, que puedes utilizar para mejorar tus habilidades para leer partituras, para mejorar tu oido musical o, simplemente, para aprender los principios fundamentales del lenguaje y la teoría de la música. Leer más ...

download button

 

Para programadores

Lomse library Librería Lomse

Lomse es una librería en C++ para proporcionar facilidades de renderizado, edición e interpretación de partituras de música. Con esta librería puedes hacer fácilmente que tus programas muestren partituras o las interpreten- Está escrita en C++, es independiente de plataforma, es gratuita y es un proyecto de código abierto. Más información

wxMidi component Componente wxMidi

wxMidi es un componente gratuito y de codigo abierto, para desarrolladores que utilicen wxWidgets. Con wxMidi puedes añadir soporte a tus aplicaciones para manejar órdenes MIDI. wxMidi es una interfaz para PortMidi (Portable Real-Time MIDI Library). Más información

Ultima actualización: 2015/12/28